https://aws-amplify.github.io/docs/cli-toolchain/usage#api-mocking-setup

Note that @searchable is not supported at this time.

https://github.com/aws-amplify/amplify-cli/issues/2524

@searchableと@predictionだけ対応していません。

またこんなissueが立ってました
https://github.com/aws-amplify/amplify-cli/issues/2524

Once this gets prioritized by the product manager we will work on this

なかなか残念な事になってるっぽいのでelasticsearch使いたい場合は大人しくawsにamplify pushしてテスト環境的なので使うしか無さそうです( ´△`)